同一Excel文件在不同电脑上用同一打印机打印出来格式不一致

最近遇到了在某Win10机器上制作的报表,换到其他机器上,用相同打印机打印结果不一致的问题。排除了Windows版本、Office版本等多种可能问题,最后发现是制作报表的机器和打印报表的机器设置的DPI不一致的原因。

原来“DPI是每英寸象素数,DPI不同显示效果是有差别的,这也是正常情况。(打印尺寸越大DPI越低)

通常打印效果受像素、分辨率等有关。例如照片的DPI一般是固定的,比如大多数机器都设定为72,那么600万象素的照片长是3400象素,每英寸72象素,那么打印出来就是长47英寸,合119厘米,大约1.2米。这种情况通常不现实,所以要调高DPI值或者减小照片分辨率,以达到最佳尺寸。”

参考:

1.http://blog.csdn.net/huangchao064/article/details/40740613

2.http://answers.microsoft.com/zh-hans/msoffice/forum/msoffice_excel-mso_winother/%E5%90%8C%E4%B8%80%[……]

继续阅读 »

[转载] RouterOS透明经济翻墙

原帖找不到了 转了个二手货 留着备用

1、设置pppoe拨号上网,建立pppoe_out,取消默认网关、默认DNS;
/interface pppoe-client –> pppoe_out(联通互联网)
2、建立pppoe-out到VPN-server的专用route通道;
/ip route 
add dst-address=x.x.x.x/32 gateway=pppoe_out
3、设置pptp连接,建立pptp_out,取消默认网关、默认DNS;
/interface pptp-client –> pptp_out(linode-pptp)
4、设置被墙IP address-list,建立GFWed(要包含被干扰的境外DNS的ip);
/ip firewall 
add address-list –> GFWed
5、标记防火墙规则,建立路由标记to_pppoe和to_pptp;
/ip firewall mangle
add action=mark-routing chain=preroutin[……]

继续阅读 »

Windows 添加永久静态路由

route -p add 10.10.10.10 mask 255.255.255.255 192.168.5.1 if 3

-p即为persistent,添加子网掩码为255.255.255.255的目标地址网络10.10.10.10,走接口3,默认网关为192.168.5.1

其中接口号可以通过route print查到[……]

继续阅读 »

Bash on Ubuntu on Windows 无法创建图标/开始菜单无应用图标 问题解决

参照微软官方教程成功安装好bash之后,每次在开始菜单都没发现有 Bash on Ubuntu on Windows的快捷方式&应用图标,也就是这个:

问了官方没回复,找到中文的相关问题解决方案一篇,不过尝试了并没有解决;之前不止一次一台电脑尝试重新安装Windows 10,也一直么看到过开始菜单上的这个图标。

问题原因暂且放一边,找到了国外的解决方案,简单的说,这篇文章提供了两种解决方案:

1.提供Bash on Ubuntu on Windows的文件下载,其实这个图标也就是个快捷方式,指向bash.exe这个执行文件,下载下来后随便放

2.从零开始一步一步的手动创建这个文件。

老外文章写的很详细,具体操作可参考。

问题找到了,见下图:

微软在生成这个快捷方式的时候,坑爹的用了全角的点,也就是句号分隔扩展名!!!


[……]

继续阅读 »

华为光猫 HG8346R(北京联通) 破解提权

北京联通发的华为光猫HG8346R,默认只有一个user用户,联通界面,基本没啥可设置的地方,尤其是不能做端口映射,不能通过DDNS外网连接,于是准备破解。参考网络资源记录如下:

1.基本思路

    通过telnet连接光猫(如果telnet也被封了,就要用相关使能工具开启之),备份配置文件;用相关工具解密配置文件,修改其中的用户权限定义;然后执行初始化为华为界面的shell脚本,恢复为全功能版本;导入修改过的配置文件。

2.详细步骤

2.1 开启光猫telnet端口(如果猫telnet默认开着,这步可跳过)

    用网线连接电脑LAN口和光猫LAN1口,拔掉光纤;打开工具 华为光猫破解工具.exe ,点一下刷新按钮,选择网卡192.168.1.*(如果有多网卡注意选择与光猫连接的网卡),其余参数不动,点击启动;光猫上的灯:POWER绿、LOS红,LAN1绿闪,等待,一直等到所有LAN灯绿色常亮,点击停止按钮,直接关闭光猫电源按钮,再开启光猫,此时telnet端[……]

继续阅读 »

PHP去掉输出http头信息中的X-Powered-By

将php.ini 中的

expose_php = On

改为

expose_php = Off

关于expose_php这个选项:

; Decides whether PHP may expose the fact that it is installed on the server
; (e.g. by adding its signature to the Web server header). It is no security
; threat in any way, but it makes it possible to determine whether you use PHP
; on your server or not.
; http://php.net/expose-php[……]

继续阅读 »

解决apache AH01630: client denied by server configuration 错误

还是迁移本博客出现的问题,配置好之后访问总是403,翻了一眼错误日志,发现提示错误:

AH01630: client denied by server configuration:
查了一下,原来是apache 2.2和2.4的配置文件发生了变化,简单摘录如下:

Deny All
2.2 configuration:
Order deny,allow
Deny from all
2.4 configuration:
Require all denied

Allow All
2.2 configuration:
Order allow,deny
Allow from all
2.4 configuration:
Require all granted

Allow Host
2.2 configuration:
Order Deny,Allow[……]

继续阅读 »

apache2 a2ensite 出现 RROR: Site does not exist!错误

迁移本博客时,在apache下用命令启用站点:

sudo a2ensite ict.jingyan.info

总是提示错误:

RROR: Site ict.jingyan.info does not exist!

查了一下,原来a2ensite系列命令为perl命令,仅处理后缀为conf相关配置文件

重命名网站配置文件之后,重新启用站点解决。

cd /etc/apache2/sites-available
sudo mv ict.jingyan.info ict.jingyan.info.conf
sudo a2ensite ict.jingyan.info.conf
sudo service apache2 restart

参考:stackoverflow[……]

继续阅读 »

CentOS配置本地yum源

1.建立本地目录
cd /media
mkdir cdrom
2.挂载CentOS光盘
mount /dev/cdrom /media/cdrom
3.配置yum源文件
vi CentOS-Media.repo,配置以下内容:
[c6-media]
name=CentOS-$releasever – Media
baseurl=file:///media/CentOS/
file:///media/cdrom/
file:///media/cdrecorder/
gpgcheck=0#改为0,不做gpgcheck
enabled=1#改为1启用
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6

4.刷新yum缓存
yum clean all[……]

继续阅读 »

Sybase 日期函数

日期函数 getdate() 得到当前时间,可以设置得到各种时间格式. datepart(日期部分,日期) 取指定时间的某一个部分,年月天时分秒. datediff(日期部分,日期1,日期2) 计算指定的日期1和日期2的时间差多少. dateadd(日期部分,数值表达式,日期) 计算指定时间,再加上表达式指定的时间长度. –取时间的某一个部分 select datepart(yy,getdate()) –year select datepart(mm,getdate()) –month select datepart(dd,getdate()) –day select datepart(hh,getdate()) –hour select datepart(mi,getdate()) –min select datepart(ss,getdate()) –sec –取星期几 //该计算出的结果要+1,因其计算出的星期天为一周的第1天,星期六自然就成为一周第7天 se[……]

继续阅读 »